jimbo74

Jimbo74's Slash 4X4 Lcg

43 posts in this topic

Esc getting too hot?

Share this post


Link to post
Share on other sites

Esc getting too hot?

I guess so..... not sure if I posted the whole story here, but Castle jerked me around in regards to my MMP.... so I am running it until it explodes....

Share this post


Link to post
Share on other sites

ok, so my slicks are 3.83" in diameter

I think I am going to drop to a 17, and give it a try.... the scriptasylum calculator is off a few mph, than what real world shows me, but it is a good baseline.... if you play around with it, you can kinda see how much difference there is between ratios....


maybe the 17 will make me not overheat.... it will drop me like 5 mph though.....

Share this post


Link to post
Share on other sites



going to need to do some more work.... speed is good, but my gears are either chewed up, or I really screwed up the mesh..... sounds like a jet engine now.....






Share this post


Link to post
Share on other sites

ok, so still hitting thermal shutdown on an mmp, on 17/54 on a 2s..... with little tires! 3.83" diameter

it is definitely the ESC. really not happy with castle.... heck, this gearing is conservative......

Share this post


Link to post
Share on other sites
oh yeah, no pics, but I used some leftover foam, and stuck it under the tab of the battery hold down.... without the strap in it, the hold down clip is forced shut all the time.... I like it :) Thanks to thesmogman from the TRX forum for that idea



here are some new pics..... I took off my lights until I can figure out a better way to moung them


slash_4x4_lcg.jpeg


truck11.jpeg


truck.jpeg


rx_box.jpeg


CC.jpeg

Share this post


Link to post
Share on other sites

so.... some stuff has happened, and it is currently down, once I get it up and running again, will update

Share this post


Link to post
Share on other sites

Running pretty good. Mmp can't handle it though. It overheats. Motor is at 120-130, geared 14/56

Battery mod

And I can use the stock bar as well

a80a567571886f6da87055a581c7fad3.jpg

Share this post


Link to post
Share on other sites

Love Tekin!! Are you going to run it unsensored?

Share this post


Link to post
Share on other sites

Motor is borrowed from a friend. He runs a pro4 hd 4300 in his slash 4x4

I do have a sensor wire on order

Share this post


Link to post
Share on other sites

It makes a great difference for low speed control and launching. I've run the RX-8 / Pro 4 combo in a few rigs and loved it every time.

Share this post


Link to post
Share on other sites

58192f986b0800ea8424d79e005e9011.jpg

Still doing some work on it. Did run the slash. Pretty legit.

My kids got a pink bandit from a friend. Had battery issues. I revived the battery on my charger. All good to go. Time to give it back to my kids

Share this post


Link to post
Share on other sites

58192f986b0800ea8424d79e005e9011.jpg Still doing some work on it. Did run the slash. Pretty legit. My kids got a pink bandit from a friend. Had battery issues. I revived the battery on my charger. All good to go. Time to give it back to my kids

time for fun.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now